System Requirements - 4.3b Module and Livelink

CAD Importing

The CAD Import Module is available for all operating systems. Please refer to the file formats table for program specifics.

LiveLink for MATLAB® Requirements

LiveLink for MATLAB® is compatible with the following versions, on all operating systems*.

COMSOL® Version Supported MATLAB® versions
COMSOL 4.3b R2012b + R2013a
COMSOL 4.3a R2012a + R2012b
COMSOL 4.3 R2011b + R2012a
COMSOL 4.2a R2011a + R2011b
COMSOL 4.2 R2010b + R2011a

*For Linux® Operating Systems, the programs xterm and csh are required. Please refer to the installation instructions for OS specific instructions.

Additional Livelinks, only available on Windows® Operating Systems

COMSOL Livelink Compatible Software
Livelink for Excel® Microsoft Excel® 2007, 2010 and 2013 on Windows®. Excel® 2010 Starter is not supported.
Livelink for SolidWorks® SolidWorks® 2012 and 2013
Livelink for SpaceClaim® SpaceClaim® 2012 or 2012+, and the Data Exchange II module available from SpaceClaim
Livelink for Inventor® Autodesk Inventor® 2013 and Autodesk Inventor® 2014
Livelink for AutoCAD® AutoCAD® 2013 and AutoCAD® 2014
Livelink for Creo Parametric Creo Parametric® 1.0 and 2.0
Livelink for Pro/ENGINEER® Wildfire® 4.0 and Wildfire® 5.0
Livelink for Solid Edge® Solid Edge® ST5

NOTE:This information is provided for your benefit but should not be used as a substitute for your own investigation of the system requirements that may be appropriate for your use of COMSOLĀ® software or other software, given your particular circumstances. Systems and hardware change regularly, which may impact any determination of what system requirements are appropriate you.

Version 4.4
Version 4.3b